Jump to content

First run!


Recommended Posts

Got the turbo b12 out on the road for the first time.

All things considered it went really well, only a handful of problems. For starters the boost gauge reads 0 at all times, but will creep up to one if i blow into it really hard. Mine's off the plenum, should it be off of the carb tops?

Also got a nice oil leak from where i drilled the pain for the turbo drain, caked the thing in sealant and crossed my fingers. 

The fuel pump likes to turn off randomly, and the only way to turn it back on is to flip the rocker switch in the other direction. Very weird. It will run and work with the switch is to the left, then turn off, and only run when you move it to the right. This yo-yos on, probably a junk switch. 

But the turbo spools, and I probably suffer from some pretty big boost leaks as the gauge reads 0 and it's not as fast as it should be. I'm going to replace all the plenum fittings, then doublecheck the hose clamps. But the bike went from being lame to floating the wheel in second, so I'd say it was successful 

Link to comment

A boost gauge on the plenum is fine - that's where most are fed from! If the gauge doesn't read, its either not working or no making boost! Is the oil drain above the running oil level? Any crankcase compression from boost will find leaks and really a welded fitting is better than a tapped and siliconed wanky joint! Your electrics seem to need attention - a switch is either on or off, wire it properly LOL!

Link to comment
3 hours ago, Gixer1460 said:

A boost gauge on the plenum is fine - that's where most are fed from! If the gauge doesn't read, its either not working or no making boost! Is the oil drain above the running oil level? Any crankcase compression from boost will find leaks and really a welded fitting is better than a tapped and siliconed wanky joint! Your electrics seem to need attention - a switch is either on or off, wire it properly LOL!

Drain is exactly where the instructions said to tap it. As for the switch, it's a cheap 3 pin rocker, I replaced it this morning and it seemed to fix the issue, couldn't say why it was doing that 

Link to comment
5 hours ago, Joseph said:

Oh well you already knew why xD

Haha yep, new switch, and redid the boost gauge, works now. 8 psi to the carbys, starting off slow. Stock ignition, busa pistons, APE studs and nuts. Aiming for 14 psi, sound safe for the motor? 

Link to comment
Posted (edited)

New issue's popped up, the battery doesn't want to charge well while riding. After it's done trickle charging I'll test voltage while running, I just replaced it last year with a high end one so it shouldn't be the issue. Only other thought is the fuel pump uses too much current.

Edited by rerb
Link to comment

Blandits usually have a fairly good output from their alternators ie. capacity for running a fuel pump, and some. Batteries do go bad but if output voltage is anything other than 13.7 - 14.4 at 2k+ rpm, i'd say the R/R is goosed!

Link to comment
11 hours ago, Gixer1460 said:

Blandits usually have a fairly good output from their alternators ie. capacity for running a fuel pump, and some. Batteries do go bad but if output voltage is anything other than 13.7 - 14.4 at 2k+ rpm, i'd say the R/R is goosed!

Looks like the case :( 9 volts at idle, 12.4 at 3k. F*cking money pit!

Link to comment

I've noticed the bike runs progressively leaner throughout the gears going WOT. Floats closing too early? 12 afr through first, 13.5 through second, then more than 14 through 3rd. 

Link to comment
8 hours ago, Gixer1460 said:

Unlikely! More likely increasing load via higher gears needing more fuel that isn't being supplied by the pump due to the low volts issues? No one said turbo bikes are easy!

Yep, figuring that out now! I was curious and popped the choke on about 30% - HUGE power increase, runs much better. Going to replace the r/r then jet up/ add shims from there

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...