Jump to content

No spark on EFE engined Katana


Recommended Posts

Hello everybody,

as the title says, my EFE engined Kat shows no sparks. I measured around everywhere I could, all I know is there should be a spark but there isn't. Changed CDI, still no spark. Is there any measurements I can take from the CDI just ot make sure both I have are not fooked?

Complete loom is also EFE btw.



Link to comment

Hmm.. I think the spark test IS the way to test a CDI. But as you've swapped it out with no change of results, it seems very likely the fault lies elsewhere. I reckon using a multimeter any generated pulses should be detectable  though, but I've never tried that myself.

To limit the number of variables (and the loom) perhaps the best way forward is making a bench setup of the ignition system. Pull the coils, signal generator and CDI from the bike and hook them up in a simple circuit a shown on the diagram in the manual. Battery can stay on the bike via leads or use a different power supply,

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...